You are not logged in.

  • Login
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

Dear visitor, welcome to Nitrado.net Prepaid Gameserver Community-Support - Archiv. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Sprax2013

User / Kunde

  • "Sprax2013" is male
  • "Sprax2013" started this thread

Posts: 189

Location: 127.0.0.1

  • Send private message

1

Friday, October 23rd 2015, 1:31pm

Versionsabhängiger import Versionsunabhängig machen? (z.B "net.minecraft.server.v1_8_R3.EnumParticle")

Hi Leute!

Bei meinem Plugin nutze ich imports die Versionsabhängig sind. Damit meine ich, dass die imports die Server-Version beinhalten. Wenn ich jetzt aber das Plugin für verschiedene Versionen lauffähig machen will muss ich ja den import anpassen. Ich habe schon gegoogelt aber ich finde nichts. Kennt einer den Namen wie man es nennt oder kann mir gleich ein beispiel geben?

Java source code

1
import net.minecraft.server.v1_8_R3.EnumParticle;
Notiz an mich selbst: Signatur ändern

ketrwu

Moderator

  • "ketrwu" is male

Posts: 1,430

Thanks: 2

  • Send private message

2

Friday, October 23rd 2015, 2:47pm

Das nennt sich Reflection. Konkreter NMS Reflection. NMS steht für net.minecraft.server.
Das sollte dir helfen: https://bukkit.org/threads/basic-reflection-tutorial.329127/

This post has been edited 1 times, last edit by "ketrwu" (Oct 23rd 2015, 2:55pm)


Sprax2013

User / Kunde

  • "Sprax2013" is male
  • "Sprax2013" started this thread

Posts: 189

Location: 127.0.0.1

  • Send private message

3

Friday, October 30th 2015, 12:17pm

Hi! Danke für die Antwort aber es klappt bei mir nicht.

Die Partikel werden nicht gespielt und der import ist in anderen Version weiterhin nicht verfügbar.
Kann es sein, dass das Tutorial schon etwas veraltet ist? Wenn nein bin ich einfach zu dumm :/

(Keine Fehler in den logs nur in der 1.7 wegen dem import)
Notiz an mich selbst: Signatur ändern

LynxPlay

User / Kunde

Posts: 122

  • Send private message

4

Friday, October 30th 2015, 1:00pm

Falls es dir nur um die Partikel geht kanst du einfach deine Spigot updaten. In einer der letzen Versionen wurden alle verfügbaren Partikel hinzugefügt
Never stop lerning or u will fall behind

PS: Electro Swing is just godlike (1931 - 1953)

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net

Similar threads