You are not logged in.

  • Login
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

Dear visitor, welcome to Nitrado.net Prepaid Gameserver Community-Support - Archiv. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Kecks2500

User / Kunde

  • "Kecks2500" started this thread

Posts: 2

  • Send private message

1

Tuesday, February 20th 2018, 4:49pm

Minecraft Plugin geht auf TestServer jedoch nicht auf anderen

Hallo,
ich habe ein Minecraft Plugin programmiert. Dieses funktioniert einwandfrei. Jedoch, wenn ich es auf einem Server welcher nicht mein TestServer ist nutze, versagt es und lädt nicht. Ich nutze einen Mac, denke aber nicht das es daran liegt.

Der Error Log in der Console:


[16:41:13 ERROR]: Could not load 'plugins\test.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError
: me/golden/test/main/Main has been compiled by a more recent version of the Jav
a Runtime (class file version 53.0), this version of the Java Runtime only recog
nizes class file versions up to 52.0


Was sollte ich nun tun?
Vielen Dank im Voraus! :)

This post has been edited 1 times, last edit by "Kecks2500" (Feb 20th 2018, 4:54pm)


ChillUpX

User / Kunde

  • "ChillUpX" is male

Posts: 1,721

Occupation: FISI Azubi

Thanks: 21

  • Send private message

2

Tuesday, February 20th 2018, 4:56pm

Der Server auf dem der Fehler auftritt hat eine zu niedrige Java Version. Wenn du das Plugin mit z.B. Java 8 kompilierst wird es auf einem Server mit Java 7 nicht laufen.

Kecks2500

User / Kunde

  • "Kecks2500" started this thread

Posts: 2

  • Send private message

3

Tuesday, February 20th 2018, 4:59pm

Okay habe ich hinbekommen, vielen Dank!!!

Jedoch habe ich noch zwei Fragen:

1: Solang das Plugin niedriger kompiliert als der Server ist gehts? Auch wenn er 5 Versionen drunter ist?

2: Welche Version sollte man verwenden, sodass es in der Regel immer funktioniert, wenn man das Plugin veröffentlichen oder verschicken sollte. bzw welche ist zu empfehlen?

:)

This post has been edited 1 times, last edit by "Kecks2500" (Feb 20th 2018, 5:06pm)


xtrumb

User / Kunde

  • "xtrumb" is male

Posts: 2,295

Location: hier

Occupation: Fachinformatiker für Systemintegration

Thanks: 16

  • Send private message

4

Tuesday, February 20th 2018, 5:47pm

Kannst es ja ausprobieren, kann ich so nicht sagen. Wäre aber quatsch :)

Java 7 ist zu empfehlen, aber wenn es keinen anderen Weg rum gibt, musst du halt Java 8 nehmen
Mit freundlichen Grüßen
TrueMB

Dienstleistungs Service
Unser Csgo Team

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net