You are not logged in.

  • Login
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

Dear visitor, welcome to Nitrado.net Prepaid Gameserver Community-Support - Archiv. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

crankshaft87

User / Kunde

  • "crankshaft87" started this thread

Posts: 7

  • Send private message

1

Tuesday, August 25th 2015, 6:10pm

Mapgroups und Mapcycle für "Workshop only!"

Ich bins nochmal. Wiederholt vielen Dank für die vorherige Antwort zu meinem Thread.

Metamod und Sourcemod laufen einwandfrei, genau wie das Multi 1v1-Plugin. Auch die Steam Workshop Maps funktionieren ohne Probleme. Wenn ich jetzt aber sm_admin, also das Adminmenü ausführe, oder bei Ablauf der Mapzeit, lädt er auch Maps, die nicht für Multi 1v1 sind. Das Adminmenü ziegt mir auch diese Maps nicht auf, sondern nur die Standard-Maps. Eine Mapgroup mit den Multi 1v1-Maps habe ich bereits erstellt und den sever damit neugestartet. Auch dann kann ich via Adminmenü leider nur die Standardmaps wählen. Ich hoffe mir kann jemand helfen, vielen Dank im Voraus!

Drakexz

Moderator

Posts: 2,126

Thanks: 18

  • Send private message

2

Tuesday, August 25th 2015, 6:48pm

Die Mapgroup sollte funktionieren, aber das Adminmenü ist statisch. Neue Maps werden nicht automaitsch hinzugefügt. Ich hab selber noch nie wirklich damit "rum gespielt" aber meines Wissens nach kannst du mit der Datei "/csgo/csgo/addons/sourcemod/configs/adminmenu_custom.txt" das Adminmenü anpassen.
Des weiteren existieren auch noch die Dateien "/csgo/csgo/maplist.txt" und "/csgo/csgo/mapcycle.txt" welche Einfluss darauf haben, welche Maps verwendet werden.

Bei Google hab ich noch folgendes gefunden:
http://sourceserver.info/board102-main/b…s-cfg-zuweisen/
Vielleicht hilft es dir. Versuchen kann ich es allerdings aktuell nicht, da ich im Moment keinen Zugriff auf CS:GO habe.
Supportanfragen via PM kann ich leider nicht beantworten. Erstelle bitte einen eigenen Thread im passenden Forenbereich.

crankshaft87

User / Kunde

  • "crankshaft87" started this thread

Posts: 7

  • Send private message

3

Tuesday, August 25th 2015, 7:52pm

Also das Menü selbst habe ich jetzt hinbekommen. Das Problem, das er nach Ablauf der Zeit eine Standardmap lädt ist nach wie vor vorhanden. Ich hab nurnoch eine Mapgroup, nämlich die mit den 1v1 Maps. Alle anderen hab ich gelöscht. Wer weiß, wo ich konfigurieren muss, damit nurnoch am_maps geladen werden? Auch nach Ablauf der Zeit?

Drakexz

Moderator

Posts: 2,126

Thanks: 18

  • Send private message

4

Wednesday, August 26th 2015, 5:04pm

Hast du dir einmal die beiden oben erwähnten Dateien "/csgo/csgo/maplist.txt" und "/csgo/csgo/mapcycle.txt" angeschaut?
Welche Karten sind denn darin enthalten?
Supportanfragen via PM kann ich leider nicht beantworten. Erstelle bitte einen eigenen Thread im passenden Forenbereich.

crankshaft87

User / Kunde

  • "crankshaft87" started this thread

Posts: 7

  • Send private message

5

Wednesday, August 26th 2015, 5:19pm

Japp, habe ich bereits umgeschrieben in:

am_anothernuke
am_rob_a
am_terrace

Das sind die 3 Maps, die derzeit rotieren sollen.

Gebe ich als Client in den chat den Befehl "nextmap" ein, sagt das SM Plugin immernoch, dass es angeblich de_dust ist :(

Drakexz

Moderator

Posts: 2,126

Thanks: 18

  • Send private message

6

Wednesday, August 26th 2015, 6:43pm

Ich weiss nicht, was bei dir falsch läuft.

Ich habe jetzt testweise einmal alles so eingestellt:
(Alles jeweils die gleichen 3 Karten)
maplist.txt => 3 maps
mapcycle => 3 maps
Mapgroup (via Webinterface) => 3 maps

Dann noch über "Counter-Strike: GO starten" die Startmap und Mapgroup entsprechend eingestellt und den Server via "Server neu starten" neu gestartet. Anschließend hat alles funktioniert. Die Startmap war die Gewünschte und nextmap hat auch die passende angezeigt als auch geladen.
Supportanfragen via PM kann ich leider nicht beantworten. Erstelle bitte einen eigenen Thread im passenden Forenbereich.

crankshaft87

User / Kunde

  • "crankshaft87" started this thread

Posts: 7

  • Send private message

7

Wednesday, August 26th 2015, 8:48pm

Also ich glaube ich verstehe von der Logik her das Interface der Mapgroups bei Nitrado nicht. Immer wenn ich nur die drei Maps auswähle via STRG und auf speichern gehe, dann stehen trotzdem anscheinend alle maps in der 1v1 group. Drake, kann man da vielleicht mal was via Teamspeak, Skype oder Teamviewer machen? Bin zum Äußersten bereit! :)

Drakexz

Moderator

Posts: 2,126

Thanks: 18

  • Send private message

8

Thursday, August 27th 2015, 5:30pm

Du gehst folgendermaßen vor:

Bearbeite deine Maplist.txt und Mapcycle.txt Datei entsprechend, dass nur die Karten enthalten sind, die auch in deiner Mapgroup enthalten sind. Ich hab beispielhaft einfach mal 3 bereits vorhandene Karten verwendet.(Bild 4)
Bild 4.png

Bild 1: Erstelle oder bearbeite deine Mapgroup und speichere sie.
Bild 1.png

Bild 2: Wähle in den Einstellungen deine Mapgroup und eine der darin enthaltenen Karten als Startmap aus und speichere es.
Bild 2.png

Bild 3: Starte deinen Server neu. (Über die Schaltfläche in Bild 2 wird das leider nicht gemacht)
Bild 3.png

Jetzt sollte dein Server mit der entsprechenden Startmap laufen und in der gamemodes_server.txt (Bild 5) sollte deine erstellte Mapgroup enthalten sein. Wenn du jetzt auf den Server gehst und nextmap eingibst, dann sollte es auch die korrekte nächste sein bzw. nach Ablauf der Zeit auf die entsprechende wechseln.
Bild 5.png

Wenn es dann nicht funktioniert, dann weiss ich nicht mehr weiter. Das waren die Schritte, die ich auf meinem Testserver ausprobiert habe mit dem Ergebnis, dass es entsprechend gepasst hat.


Privaten Support via PM / Skype / Steam etc. gebe ich leider nicht. Das wird viel zu unübersichtlich und hier im Forum haben ggf. auch andere Nutzer etwas von den Tipps / der Lösung. Sorry.
Supportanfragen via PM kann ich leider nicht beantworten. Erstelle bitte einen eigenen Thread im passenden Forenbereich.

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net