You are not logged in.

  • Login
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

Dear visitor, welcome to Nitrado.net Prepaid Gameserver Community-Support - Archiv. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

1

Sunday, September 28th 2014, 5:45pm

Die letzte Fehlermeldung...:D

Huhu,

so nun bitte ein letztes Mal:

auf meinem Epoch Panthera2 Server

aktuelle Versionen / patches sind drauf.

In der Log -> RPT findet sich eine Fehlermeldung, die ich
derzeit nicht so recht einordnen / ausbessern kann:

if (_hiveLoaded) then {

_vehLimit = MaxVehi>
14:24:25 Error position: <_hiveLoaded) then {

_vehLimit = MaxVehi>
14:24:25 Error Undefined variable in expression: _hiveloaded
14:24:25 File z\addons\dayz_server\system\server_monitor.sqf, line 425


ich hänge mal die server monitor an.
DECO1919 has attached the following file:

Wallnuss

User / Kunde

Posts: 746

Thanks: 2

  • Send private message

2

Sunday, September 28th 2014, 7:55pm

Hi

Schau dir mal die anzahl deiner gespawnten Fahrzeuge in der init an wo du die menge definierst hab da so was im Kopf das es genau daran liegt du hast mehr Fahrzeuge auf der Map als es sein sollen

mfg nuss

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

3

Sunday, September 28th 2014, 7:57pm

Hey,

unsere Map ist derzeit leer, sprich keine gespawnten Fahrzeuge.

Sowohl im Interface, als auch in der Init steht unser Wert auf 300

Blah1302

User / Kunde

  • "Blah1302" is male

Posts: 2,674

Location: NRW

Thanks: 25

  • Send private message

4

Sunday, September 28th 2014, 8:05pm

Dann schau mal nach wie viele in der Dynamic_Vehicle.sqf definiert sind und wie viele du spawnen lassen möchtest. Ich kann mich daran erinnern das die stock Werte schon den Fehler verursacht haben. In der Dynamic sind um die 250 eingetragen und stock will er 300 spawnen.
Einfach ein bisschen an der Anzahl in der dynamic hoch schrauben.
Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen.
Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

5

Sunday, September 28th 2014, 10:10pm

Dann werde ich damit mal rumspielen.

Wir hatten die Dynamic_Vehicle.sqf bearbeitet und zB die Wasserfahrzeuge rausgelöscht.
Im Anschluss wurden alle vorhandenen Fahrzeuge auf der Map zerstört.
Der Grundgedanke war, dass er mit der aktualisierten Liste spawnt.

War etwas daran falsch?

This post has been edited 3 times, last edit by "DECO1919" (Sep 28th 2014, 10:42pm)


NormanFighting

User / Kunde

  • "NormanFighting" is male

Posts: 701

Location: Memmingen

Occupation: Lagerist

Thanks: 22

  • Send private message

6

Sunday, September 28th 2014, 10:39pm

Lad mal bitte die dynamic vehicles.sqf hier hoch, damit man sich die mal anschauen kann.
"A computer is a System, do you understand? If I do what I do, it is only to explore a system." - John Draper aka. Captain Crunch

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

7

Sunday, September 28th 2014, 10:43pm

Ich sehe gerade die MYSQL ist nach wie vor voll mit Fahrzeugen,
sie haben zwar die ID 0, aber sind aufgeführt



Hier unsere dynamic_vehicle
DECO1919 has attached the following file:

NormanFighting

User / Kunde

  • "NormanFighting" is male

Posts: 701

Location: Memmingen

Occupation: Lagerist

Thanks: 22

  • Send private message

8

Sunday, September 28th 2014, 10:51pm

Du hast in der dynamic vehicle alleine schon 302 Fahrzeuge angegeben, wenn wir davon ausgehen, daß i.d.R. jeweils 1 mehr spawned, als angegeben (Softlimit - die Diskussion hatten wir die Tage ja schon mal) dann versucht der Server 600 Fahrzeuge zu spawnen, auf wieviel ist das Vehicle Limit eingestellt?
"A computer is a System, do you understand? If I do what I do, it is only to explore a system." - John Draper aka. Captain Crunch

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

9

Sunday, September 28th 2014, 10:55pm

Huhu, das Fahrzeuglimit liegt bei 300 derzeit, wohl mit der Liste viel zu wenig :D

Ist es egal, dass die Datenbank trotz leerer Map so voll ist mit den Fahrzeugen?

NormanFighting

User / Kunde

  • "NormanFighting" is male

Posts: 701

Location: Memmingen

Occupation: Lagerist

Thanks: 22

  • Send private message

10

Sunday, September 28th 2014, 10:58pm

Das kann ich dir gar nicht genau sagen, ich denke mal, der schreibt die Datenbank mit den Fahrzeugen voll, auch wenn sie nicht physisch gespawned sind. Setz einfach mal das Vehicle Limit auf 1000, dann spawned er bestimmt die ganzen Fahrzeuge an den Koordinaten, die in der DB angegeben sind. Allerdings würde ich für längerfristig empfehlen, eher die Anzahl der Fahrzeuge in der dynamic vehicle zu verringern.
"A computer is a System, do you understand? If I do what I do, it is only to explore a system." - John Draper aka. Captain Crunch

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

11

Sunday, September 28th 2014, 11:00pm

Ich bedanke mich recht herzlich bei dir!
Manchmal wird man echt betriebsblind! :doofy:

Ich teste das mal und berichte dann wieder.

Grüße, Sebi



Edit:

Nach nochmaliger Bearbeitung der dynamic_vehicle Liste und
Erhöhung des Vehicle-Limit,
erscheint immer noch die Fehlermeldung und es passiert nichts.
Auch mit der Standard-Vehicle Spawn Liste klappt nix...


Habt ihr weitere Ideen?

This post has been edited 2 times, last edit by "DECO1919" (Sep 29th 2014, 6:25pm)


Keiry

User / Kunde

Posts: 3

  • Send private message

12

Monday, September 29th 2014, 6:33pm

kleines Update

Hallo,

kleines Update zu unserem Problem: wir haben jetzt die originale vehicle_spawn Datei auf dem Server, was keine Änderung gebracht hat. 2 Anrufe beim Support haben uns nicht weitergebracht. Aus der MySQL habe ich manuell alle Fahrzeuge gelöscht in der Hoffnung auf ein Ergebnis. Bis jetzt sind keine neuen Fahrzeuge gespawnt.

Die Fehlermeldung soll laut Support uninteressant sein, da der Hive in dieser Hinsicht nicht mehr in Benutzung oder nicht mehr aktuell ist. Das können wir also ignorieren.

Mlg

Keiry von den Frostwölfen

NormanFighting

User / Kunde

  • "NormanFighting" is male

Posts: 701

Location: Memmingen

Occupation: Lagerist

Thanks: 22

  • Send private message

13

Monday, September 29th 2014, 6:46pm

Habt ihr den Server zwischenzeitlich mal komplett neu aufgesetzt, also deinstalliert und neu installiert? Falls nicht, würde ich das an eurer Stelle versuchen. Manchmal ist das ganze "System" so durcheinander, daß ein bloßes Austauschen der Dateien nichts mehr bringt.
"A computer is a System, do you understand? If I do what I do, it is only to explore a system." - John Draper aka. Captain Crunch

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

14

Monday, September 29th 2014, 7:15pm

Hey Kelly,

kannst du uns vielleicht sagen, wann / wie respektive wie oft Fahrzeuge nachspawnen?
Sonst warten wir uns hier einen Ast und müssten eigtl. zB eine ganze Woche warten.

Wenn es nicht zu viel verlangt ist, könntest du uns bitte mal deine server_monitor zum abgleich zeigen?

Das wäre super! :D

NormanFighting

User / Kunde

  • "NormanFighting" is male

Posts: 701

Location: Memmingen

Occupation: Lagerist

Thanks: 22

  • Send private message

15

Monday, September 29th 2014, 7:28pm

Hier habt ihr meine Server Monitor, und das mit dem spawnen der Fahrzeuge könnt ihr mehr oder weniger in Echtzeit verfolgen, wenn ihr im infinstar Admintool den "Admin Debug" aktiviert, da zeigt er euch im Debug Monitor z.B. 270/500 an (also in diesem Fall 270 von 500 gespawned) usw.
NormanFighting has attached the following file:
"A computer is a System, do you understand? If I do what I do, it is only to explore a system." - John Draper aka. Captain Crunch

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

16

Monday, September 29th 2014, 7:42pm

Darf ich dir vielleicht mal meine server_monitor posten?
Einen "kleinen Verdacht" habe ich ja, dass es dort rumort.

Dort drin ist:
- indestructable Basebuilding
- Vector Build
DECO1919 has attached the following file:

NormanFighting

User / Kunde

  • "NormanFighting" is male

Posts: 701

Location: Memmingen

Occupation: Lagerist

Thanks: 22

  • Send private message

17

Monday, September 29th 2014, 7:52pm

Da muss ich leider passen, denn bei Vector Build und Indestructable Basebuilding kenn ich mich Null aus, nie damit befasst, muss sich jemand anderst anschauen.
"A computer is a System, do you understand? If I do what I do, it is only to explore a system." - John Draper aka. Captain Crunch

DECO1919

User / Kunde

  • "DECO1919" started this thread

Posts: 59

  • Send private message

18

Tuesday, September 30th 2014, 2:58am

Hallo Kelly,

also deine Server_monitor hat uns zumindest zum spawnen verholfen!
Danke dafür :D

Ich bräuchte bitte nur noch die originalen maxVehicle Werte aus der init.sqf
und dem Webinterface (da denke ich ist es 500?)

Ich hab derzeit beides auf 500 stehen, komme aber nicht mehr drauf.
Folgende log:

2:57:46 Error Undefined variable in expression: _vehicle
2:57:46 File z\addons\dayz_server\init\server_functions.sqf, line 249
2:57:46 Error in expression <imit = _random select 1;

_qty = {_x == _vehicle} count serverVehicleCounter;


>
2:57:46 Error position: <_vehicle} count serverVehicleCounter;



Laut meiner Suche ist das auf eine Unstimmigkeit zwischen den maxVehicle Limits zurückzuführen

JannisJoppich

User / Kunde

Posts: 267

Thanks: 2

  • Send private message

19

Tuesday, September 30th 2014, 3:44am

Hi Deco,

möchte mich da kurz einklinken.

Deine Fehlermeldung hatte ich auch und das bereits nach NEUINSTERLATION des servers, die kommt also von Nitrado, iwie pennen die beim bereitstellen der insterlation.
Übersetz dir die Meldung mal ins deutsch dann kommste selbst als noob wie ich einer bin drauf :D^^


2:57:46 Error Undefined variable in expression: _vehicle heißt dein server hat hier eine undefinierbare variable, warum die undefinierbar ist siehste gleich

2:57:46 File z\addons\dayz_server\init\server_functions.sqf, line 249 hier sagt dir die Log wo du die datei findest, geh da mal hin und schau dir das an ;)

2:57:46 Error in expression <imit = _random select 1; sieh mal an , in der datei steht er soll "imit = _random select 1; ausführen, da ich und scheinbar auch der server nicht weiß was das sein soll.....geht das mal nicht die zeile darüber besagt aber das gleiche mit dem Wortlaut _vehicle = _random select 0 / nun habe ich die imit zeile einfach entfehrnt und mich für random 1 entschieden.


Spoiler Spoiler

ich glaube es hatte was mit dem spawnen von autos zu tun, lies dir einfach mal durch was diese zeile besagt in der init, nachdem ich das allerdings geändert hatte, kam ne andere fehlermeldung die ich nun laaange suchen musste, hatte jedoch null auswirkung auf den server, daher habe ich die ignoriert ^^
Sollte jemand hier einwände im vorgang haben bitte sofort korrigieren dann zieh ich mein Beitrag zurück ^^


//edit
habe dein beitrag nicht richtig gelesen, du kommst nicht auf dein Server ?? Das sollte NICHT an dieser Meldung liegen, suche nach einem anderen Problem, bei mir kam diese Meldung im Log aber ich konnte drauf !

KiloSwiss

ArmA Freidenker

  • "KiloSwiss" is male

Posts: 4,016

Location: Feruz Abad

Occupation: SQF

Thanks: 295

  • Send private message

20

Tuesday, September 30th 2014, 6:45am

Undefiniert, nicht undefinierbar (jede Variable ist frei definierbar) und weisst du was select für eine Funktion hat?

» Meine Dateien (Arma3 & CSGO): Dropbox «

» Spenden für ein Bierchen: PayPal :beer: «

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net