Sie sind nicht angemeldet.

  • Anmelden
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

Lieber Besucher, herzlich willkommen bei: Nitrado.net Prepaid Gameserver Community-Support - Archiv. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

tweety060286

User / Kunde

  • »tweety060286« ist männlich
  • »tweety060286« ist der Autor dieses Themas

Beiträge: 749

  • Nachricht senden

1

Sonntag, 1. März 2015, 16:30

Vehicle Spawn

Und hiermit Frage nummer 2 ;)

Bitte Korrigiert mich wenn ich falsch liege aber..

in der Init Sqf sag ich ja wiviele Fahrzeuge maximal auf meiner map sein dürfen unter:

PHP-Quelltext

1
MaxVehicleLimit 300;     


also sind ja 300 die drauf sein dürfen.

in der dynamic_vehicle sqf befinden sich all jene Fahrzeuge und anzahl die eben nach dem restart spawnen ( name wird mitgezählt ist mir klar )

so da ich nun Probleme hatte mit dem Admintool Fahrzeuge zu spawnen oder Leute die welche kauften und die Fahrzeuge jedoch sofort despawnt sind ,
habe ich mir gedacht ich erhöhe in der Init sqf eben die MaxVehicleLimit auf 800 !

Mehr hab ich gar nicht umgestellt und nun kommt der typische Fehler vom Vehicle spawn den ich beseitigen möchte. kann mir da jemand sagen wie ? muss ich die Spawnanzahl in der dynamic vehicle auf die 600 stellen ? eher nicht denke ich !

also woran liegt nun folgender Fehler ?

Spoiler Spoiler

16:28:46 Error Undefined variable in expression: _vehicle
16:28:46 File z\addons\dayz_server\init\server_functions.sqf, line 251
16:28:46 Error in expression <limit = _random select 1;
_qty = {_x == _vehicle} count serverVehicleCounter;

i>
16:28:46 Error position: <_vehicle} count serverVehicleCounter;

i>
16:28:46 Error Undefined variable in expression: _vehicle
16:28:46 File z\addons\dayz_server\init\server_functions.sqf, line 251
16:28:47 Error in expression <limit = _random select 1;
_qty = {_x == _vehicle} count serverVehicleCounter;

i>
16:28:47 Error position: <_vehicle} count serverVehicleCounter;

i>
16:28:47 Error Undefined variable in expression: _vehicle
16:28:47 File z\addons\dayz_server\init\server_functions.sqf, line 251
16:28:47 Error in expression <limit = _random select 1;
_qty = {_x == _vehicle} count serverVehicleCounter;

i>
16:28:47 Error position: <_vehicle} count serverVehicleCounter;

i>
16:28:47 Error Undefined variable in expression: _vehicle
16:28:47 File z\addons\dayz_server\init\server_functions.sqf, line 251
16:28:48 Error in expression <limit = _random select 1;


hier noch der Ausschnit von der server funktion sqf line 251:

Spoiler Spoiler


_index = floor random count AllowedVehiclesList;
_random = AllowedVehiclesList select _index;
_vehicle = _random select 0;
_velimit = _random select 1;
_qty = {_x == _vehicle} count serverVehicleCounter;

if (_qty <= _velimit) exitWith {};

_lastIndex = (count AllowedVehiclesList) - 1;

if (_lastIndex != _index) then {
AllowedVehiclesList set [_index, AllowedVehiclesList select _lastIndex];
};

AllowedVehiclesList resize _lastIndex;
};

if (count AllowedVehiclesList == 0) then {
diag_log("DEBUG: unable to find suitable vehicle to spawn");
} else {

serverVehicleCounter set [count serverVehicleCounter,_vehicle];
[Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]

Blah1302

User / Kunde

  • »Blah1302« ist männlich

Beiträge: 2 674

Wohnort: NRW

Danksagungen: 25

  • Nachricht senden

2

Sonntag, 1. März 2015, 16:34

Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen.
Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.

tweety060286

User / Kunde

  • »tweety060286« ist männlich
  • »tweety060286« ist der Autor dieses Themas

Beiträge: 749

  • Nachricht senden

3

Sonntag, 1. März 2015, 19:31

okay vestehe es eh und hab auch echt einiges gefunden . aber vl war meine fragestellung nicht korrekt.

bei mir spawnen keine fahrzeuge mehr auch wenn ich mit dem admintool welche spawne oder leute sich welche kaufen , dann despawnen die wieder.

nicht immer aber oft .

woran kann das liegen ?

an der begrenzung der max erlaubten fahrzeuge nehm ich mal an und alles was drüber geht löscht infistar also muss ich das wo erhöhen .

wo mach ich das ?

lg
[Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]

Blah1302

User / Kunde

  • »Blah1302« ist männlich

Beiträge: 2 674

Wohnort: NRW

Danksagungen: 25

  • Nachricht senden

4

Sonntag, 1. März 2015, 19:37

Ich habe nur in den Spoiler deiner .rpt geschaut, und dir die Lösung dazu als Link geschrieben.
Wenn das behoben ist könnten auch die anderen Probleme behoben sein.
Die deutsche Sprache ist Freeware, du kannst sie benutzen, ohne dafür zu bezahlen.
Sie ist aber nicht Open Source, also darfst du sie nicht verändern, wie es dir gerade passt.

tweety060286

User / Kunde

  • »tweety060286« ist männlich
  • »tweety060286« ist der Autor dieses Themas

Beiträge: 749

  • Nachricht senden

5

Sonntag, 1. März 2015, 19:58

nein nein das problem hatte ich ja vor dem error hier ;)

dehalb hab ich ja nur probeweise mal das in der init erhöht um zu kucken was passiert.

fahrzeuge verschinden noch immer und der fehler ist eben auch nun da.

wie ich den fehler wieder wegbekomme weiss ich ja indem ich es wieder zurücksetze aber deshalb ist das problem ja nicht gelöst das meine fahrzeueg despawnen ;)

hast da auch ne lösung ich denk da an das webinterface unter einstellungen Max Fahrzeugmenge auf der Map

kann ich da richtig liegen.

sprich ich stell das in der Init wieder zurück und erhöhe es im Webinterface ;)

LG tweety
[Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]

Wallnuss

User / Kunde

Beiträge: 746

Danksagungen: 2

  • Nachricht senden

6

Montag, 2. März 2015, 00:15

im Webinterface

Vehicle Tradercheck: x

Vehicle Valid ID ?: x

damit wurde es viel besser das die Fahrzeuge nach dem kaufen despawnen (oder beim adminspawn) eine 100% lösung gibt es da wohl nicht

nuss

tweety060286

User / Kunde

  • »tweety060286« ist männlich
  • »tweety060286« ist der Autor dieses Themas

Beiträge: 749

  • Nachricht senden

7

Montag, 2. März 2015, 08:26

Danke wallnuss. Werds gleich mal testen

Lg tweety
[Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net