You are not logged in.

  • Login
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

Dear visitor, welcome to Nitrado.net Prepaid Gameserver Community-Support - Archiv. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Jongartv

User / Kunde

  • "Jongartv" started this thread

Posts: 20

  • Send private message

1

Saturday, November 25th 2017, 12:00pm

Fehler in Konsole

Hallo liebes Nitrado forum;

Minecraft-Version:
1.8.9

Arbeitsspeicher/RAM:


Problembeschreibung:
ich habe ein plugin doch es kommt immer dieser fehler:

Serverlog/Latestlog als Anhang:

[11:52:57 ERROR]: Could not load 'plugins\BuyHearts.jar' in folder 'plugins'
org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:164) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.craftbukkit.v1_8_R3.CraftServer.reload(CraftServer.java:739) [spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.Bukkit.reload(Bukkit.java:535) [spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:641) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.PlayerConnection.handleCommand(PlayerConnection.java:1162) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:997) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13) [spigot.jar:git-Spigot-db6de12-18fbb24]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_131]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_131]
at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot.jar:git-Spigot-db6de12-18fbb24]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_131]
Caused by: org.yaml.snakeyaml.error.YAMLException: java.nio.charset.MalformedInputException: Input length = 1
at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:200) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:60) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.yaml.snakeyaml.Yaml.load(Yaml.java:381) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:232) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:159) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
... 20 more
Caused by: java.nio.charset.MalformedInputException: Input length = 1
at java.nio.charset.CoderResult.throwException(CoderResult.java:281) ~[?:1.8.0_131]
at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:339) ~[?:1.8.0_131]
at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178) ~[?:1.8.0_131]
at java.io.InputStreamReader.read(InputStreamReader.java:184) ~[?:1.8.0_131]
at org.yaml.snakeyaml.reader.UnicodeReader.read(UnicodeReader.java:123) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at java.io.Reader.read(Reader.java:140) ~[?:1.8.0_131]
at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:184) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:60) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.yaml.snakeyaml.Yaml.load(Yaml.java:381) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:232) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:159) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
... 20 more
installierte Plugins:
PermissionsEX
SetSpawn
MCMoney
Vault
Spawn
Jobs
ASkyblock


LinXX

User / Kunde

Posts: 1,018

Occupation: Azubi Fachinformatiker für Systemintegration

  • Send private message

2

Saturday, November 25th 2017, 5:52pm

1. Schick uns den Code
oder
2. Wenn es nicht von dir ist, schick en Fehler dem Entwickler

MFG

Jongartv

User / Kunde

  • "Jongartv" started this thread

Posts: 20

  • Send private message

3

Saturday, November 25th 2017, 6:27pm

LinXX fehlermeldung

LinXX fehlermeldung :

beim exportieren der datei kommt jetzt das:

Jar creation failed. See details for addtional information.


JAR creation failed. See details for additional information.
byHearts/META-INF/MANIFEST.MF was replaced by the generated MANIFEST.MF and is no longer in the JAR.
me/truemb/buyhearts/api [in byHearts] is not on its project's build path
Unable to get package fragment root: byHearts/me/truemb/buyhearts/api/UTF8YamlConfiguration.java
me/truemb/buyhearts/api [in byHearts] is not on its project's build path
me/truemb/buyhearts/commands [in byHearts] is not on its project's build path
Unable to get package fragment root: byHearts/me/truemb/buyhearts/commands/HeartCommand.java
me/truemb/buyhearts/commands [in byHearts] is not on its project's build path
me/truemb/buyhearts/main [in byHearts] is not on its project's build path
Unable to get package fragment root: byHearts/me/truemb/buyhearts/main/Main.java
me/truemb/buyhearts/main [in byHearts] is not on its project's build path






Jongartv has attached the following file:
  • BuyHearts.jar (4.78 kB - 3 times downloaded - latest: Nov 27th 2017, 10:44am)

This post has been edited 2 times, last edit by "Jongartv" (Nov 25th 2017, 8:02pm)


LinXX

User / Kunde

Posts: 1,018

Occupation: Azubi Fachinformatiker für Systemintegration

  • Send private message

4

Saturday, November 25th 2017, 7:19pm

"Caused by: org.yaml.snakeyaml.error.YAMLException: java.nio.charset.MalformedInputException: Input length = 1"
Irgentwas in deiner plugin,yml ist Falsch formatiert, du solltest die mal überprüfen.

Jongartv

User / Kunde

  • "Jongartv" started this thread

Posts: 20

  • Send private message

5

Saturday, November 25th 2017, 7:57pm

LinXX

LinXX,
wenn ich die datei exportieren will steht bei mir das:


Jar creation failed. See details for additional information.



JAR creation failed. See details for additional information.
byHearts/META-INF/MANIFEST.MF was replaced by the generated MANIFEST.MF and is no longer in the JAR.
me/truemb/buyhearts/api [in byHearts] is not on its project's build path
Unable to get package fragment root: byHearts/me/truemb/buyhearts/api/UTF8YamlConfiguration.java
me/truemb/buyhearts/api [in byHearts] is not on its project's build path
me/truemb/buyhearts/commands [in byHearts] is not on its project's build path
Unable to get package fragment root: byHearts/me/truemb/buyhearts/commands/HeartCommand.java
me/truemb/buyhearts/commands [in byHearts] is not on its project's build path
me/truemb/buyhearts/main [in byHearts] is not on its project's build path
Unable to get package fragment root: byHearts/me/truemb/buyhearts/main/Main.java
me/truemb/buyhearts/main [in byHearts] is not on its project's build path

xtrumb

User / Kunde

  • "xtrumb" is male

Posts: 2,295

Location: hier

Occupation: Fachinformatiker für Systemintegration

Thanks: 16

  • Send private message

6

Monday, November 27th 2017, 8:19am

Einfach ein bisschen warten und ich fixe es dir ^^

PS: Ich finde es nicht so nice, wenn man mich als Dev von dem Plugin rausnimmt, was ich kostenlos gemacht habe. (Nur eine kleine Anmerkung)
Mit freundlichen Grüßen
TrueMB

Dienstleistungs Service
Unser Csgo Team

LinXX

User / Kunde

Posts: 1,018

Occupation: Azubi Fachinformatiker für Systemintegration

  • Send private message

7

Monday, November 27th 2017, 4:08pm



2. Wenn es nicht von dir ist, schick en Fehler dem Entwickler


me/truemb/buyhearts/main [in byHearts] is not on its project's build path

BestPixelHD

User / Kunde

  • "BestPixelHD" is male

Posts: 31

  • Send private message

8

Monday, November 27th 2017, 6:22pm

So wäre ein plugin.yml aufgebaut: https://forum.pixelhype.net/index.php?th…ptionexception/

author:
version:
....


Wichtig ist, dass immer ein doppelpunkt da ist :)
Liebe Grüße, Pixel
-> Ich bin euch immer ein Pixel vorraus! :)
-> Ohne mich würdet ihr Minecraft nicht spielen können :P


Das PixelHype-Netzwerk: https://forum.pixelhype.net/

xtrumb

User / Kunde

  • "xtrumb" is male

Posts: 2,295

Location: hier

Occupation: Fachinformatiker für Systemintegration

Thanks: 16

  • Send private message

9

Wednesday, November 29th 2017, 9:22am

Der Fehler war nur ein ü, dass ich ausversehen in der plugin.yml gesetzt habe.
Mit freundlichen Grüßen
TrueMB

Dienstleistungs Service
Unser Csgo Team

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net