You are not logged in.

  • Login
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

Dear visitor, welcome to Nitrado.net Prepaid Gameserver Community-Support - Archiv. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

1

Sunday, June 12th 2011, 3:59pm

[Frage] WorldGuard Mobs DEAktivieren? block-creature-spawn: []

Hallo, ich habe mal eine Frage wegen WorldGuard:

Wie kann ich in der Config mit der Option

Source code

1
2
3
4
5
mobs:
block-creeper-explosions: on
block-creeper-block-damage: on
block-creature-spawn: []
anti-wolf-dumbness: false


dieses "block-creature-spawn: []" Wie muss ich da was schreiben um ALLE Monster/Tiere/etc aus zu schalten?

Problem ist folgendes: Ich habe eine Flache Map gemacht, unsere "ART" Welt, PixelArt, Statuen etc... Die Ebene auf der man baut ist Y = 3.
PROBLEM: SLIMES - überall ... Da Mobs sowieso da stören wollte ich eben wissen, wie ich die Viehcher da aus bekomme... - und zwar mit WorldGuard und ohne extra Plugin!

Vielen Dank!
STEAM: crypton25

IHaTeD2

User / Kunde

Posts: 1,022

  • Send private message

2

Sunday, June 12th 2011, 4:54pm

Und wieso stellst du in der config nicht einfach Spawn monsters und animals auf false?
! Kein Support per PM !

Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

3

Sunday, June 12th 2011, 5:13pm

Weil dann in unserer Hauptwelt und im Nether auch nichts mehr los wäre...
Oder wo genau meinst du jetzt?
Komplette config:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
#
# WorldGuard's configuration file.
#
# This is the a per-world configuration file. It only affects one
# corresponding world.
#
# About editing this file:
# - DO NOT USE TABS. You MUST use spaces or Bukkit will complain. If
#   you use an editor like Notepad++ (recommended for Windows users), you
#   must configure it to "replace tabs with spaces." In Notepad++, this can
#   be changed in Settings > Preferences > Language Menu.
# - Don't get rid of the indents. They are indented so some entries are
#   in categories (like "enforce-single-session" is in the "protection"
#   category.
# - If you want to check the format of this file before putting it
#   into WorldGuard, paste it into http://yaml-online-parser.appspot.com/
#   and see if it gives "ERROR:".
# - Lines starting with # are comments and so they are ignored.
#

summary-on-start: on
pumpkin-scuba: off

protection:
    item-durability: on
    remove-infinite-stacks: off

simulation:
    sponge:
        enable: off
        redstone: off
        radius: 3

physics:
    no-physics-gravel: on
    no-physics-sand: on
    allow-portal-anywhere: off
    disable-water-damage-blocks: []

ignition:
    block-tnt: on
    block-lighter: on

fire:
    disable-all-fire-spread: on
    disable-fire-spread-blocks: []
    disable-lava-fire-spread: on
    lava-spread-blocks: []

weather:
    disable-lightning-strike-fire: on
    prevent-lightning-strike-blocks: []
    # The following don't work yet
    disable-weather: off
    disable-thunderstorm: off
    disable-pig-zombification: off
    always-raining: off
    always-thundering: off
    disable-powered-creepers: off

mobs:
    block-creeper-explosions: on
    block-creeper-block-damage: on
    block-creature-spawn: []
    anti-wolf-dumbness: false

spawn:
    login-protection: 3
    spawn-protection: 0
    kick-on-death: off
    exact-respawn: off
    teleport-to-home-on-death: off

player-damage:
    disable-fall-damage: on
    disable-lava-damage: on
    disable-fire-damage: on
    disable-lightning-damage: on
    disable-drowning-damage: on
    disable-suffocation-damage: on
    disable-contact-damage: on
    teleport-on-suffocation: off
    disable-void-damage: off
    teleport-on-void-falling: off

regions:
    enable: off
    wand: 287
    max-claim-volume: 30000
    claim-only-inside-existing-regions: off
    max-region-count-per-player: 7
    high-frequency-flags: off

iconomy:
    enable: off
    buy-on-claim: on
    # Price per block for buying on claim
    buy-on-claim-price: 2

chest-protection:
    enable: off

crops:
    disable-creature-trampling: on
    disable-player-trampling: on

blacklist:
    use-as-whitelist: off
    logging:
        console:
            enable: on
        database:
            enable: off
            dsn: jdbc:mysql://localhost:3306/minecraft
            user: root
            password: pass
            table: blacklist_events
        file:
            enable: on
            path: worldguard/logs/%w-%Y-%m-%d.log
            open-files: 10
STEAM: crypton25

Konrad

User / Kunde

  • "Konrad" is male

Posts: 491

Location: Irgendwo in Niedersachsen

Occupation: Schüler

  • Send private message

4

Sunday, June 12th 2011, 6:57pm

Du kannst eine Liste von Monstern machen die nicht Spawnen sollen. Z.B:

block-creature-spawn: [slime,zombie,...]

Ich glaube du musst alle Monster einzeln eintragen.

Zitat

Ihre Maus und Tastatur funktionieren nicht mehr. Drücken sie eine beliebige Taste um fortzufahren.

Meine Rechtschreibfehler gehören zu meinem geistigen Eigentum und dürfen nicht kopiert werden ™ ® :thumbsup:

Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

5

Sunday, June 12th 2011, 7:59pm

Du kannst eine Liste von Monstern machen die nicht Spawnen sollen. Z.B:

block-creature-spawn: [slime,zombie,...]

Ich glaube du musst alle Monster einzeln eintragen.



Ich werds mal versuchen.
STEAM: crypton25

Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

6

Sunday, June 12th 2011, 8:08pm

Er sagt bei reloaden

Source code

1
WARNING: WorldGuard. Unkown mob type 'pig'
zum Beispiel. Das mit allen Tieren&Monstern
hab auch nochmal im WorldGuardWiki geschaut, da aber nichts gefunden...
STEAM: crypton25

Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

7

Monday, June 13th 2011, 11:52am

-Push-
Problem besteht noch :/
STEAM: crypton25

IHaTeD2

User / Kunde

Posts: 1,022

  • Send private message

8

Monday, June 13th 2011, 12:42pm

Ich vermute das die Mobs auch eine ID haben die man eintragen muss oder der Syntax stimmt evt. nicht.

Generell würde ich aber mal im WG Thread fragen - die wissen da vermutlich mehr.
! Kein Support per PM !

Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

9

Monday, June 13th 2011, 12:49pm

Gut, dann mach ich das mal :)

Ich sag dann bescheid wie, dann hat jeder was davon :D
STEAM: crypton25

IHaTeD2

User / Kunde

Posts: 1,022

  • Send private message

10

Monday, June 13th 2011, 1:55pm

Wenn nicht motz ich gleich mal. :D
Machen leider viel zu wenige.
! Kein Support per PM !

Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

11

Tuesday, June 14th 2011, 10:20am

Ich hatte noch nicht genatwortet, weil ich noch nichts habe was hilft :)

Also die Antwort war:

Quoted


Try the mob-spawning flag
Chat command:
Code:

Source code

1
/region flag __global__ mob-spawning deny




allerdings hat weder __global__ noch "ART" funktioniert, ich hatte vorher die komplette MAP als "ART" definiert.
Ich bekome zwar immer die Meldung, dass die flag aktualisiert wurde oder so, allerdings hüpfen trotzdem überall Slimes, Schafe, etc rum...

In der richtigen welt habe ich zum Test mal PVP nur in der "City" verboten. Hab danach mal ein test-opfer geschlagen und schon kam die Meldung das ich in einer nicht PVP Zone bin. (Der Player hat keinen Schaden bekommen)
STEAM: crypton25

darcion

User / Kunde

  • "darcion" is male

Posts: 655

Occupation: Informatiker

Thanks: 23

  • Send private message

12

Tuesday, June 14th 2011, 2:08pm

wenns zu schwer wird, es gibt ein leichtgewicht unter so einer vorraussetzung was ers vereinfacht.

NoSpawn, es kann verschiedene Monster und Welten und die Blöcke auf denen sie spawnen beeinflussen. Sehr zu empfehlen

_NameLess_

Moderator im Ruhestand

  • "_NameLess_" is male

Posts: 8,321

Location: Tirol, Österreich

Occupation: Studierender | Foren-Moderator | Anime Hero | Nitrado Minecraft Testserver

Thanks: 16

  • Send private message

13

Tuesday, June 14th 2011, 8:23pm

Hey

Ich glaube er kennt den mob nicht, weil man ihn groß schreiben muss. Also "Pig" statt "pig", aber ich denke das wurde bereits versucht ;)

Ist ja beim /spawnmob command auch so ..;D



MFG
Name
Die deutsche Sprache ist Freeware.
Das heißt, du darfst sie uneingeschränkt nutzen. ABER(!) die deutsche Sprache ist NICHT Open Source.
Das heißt, du darfst sie nicht nach deinen Vorstellungen verändern!

Ein Problem ist halb gelöst, wenn es klar formuliert ist.

This post has been edited 1 times, last edit by "_NameLess_" (Jun 27th 2011, 1:40am)


Crypton25

User / Kunde

  • "Crypton25" is male
  • "Crypton25" started this thread

Posts: 73

Location: iwo im Taunus

Occupation: Schüler

Thanks: 1

  • Send private message

14

Monday, June 27th 2011, 12:26am

Hey

Ich glaube er kennt dan mob nicht, weil man ihn groß schreiben muss. Also "Pig" statt "pig", aber ich denke das wurde bereits versucht ;)

Ist ja beim /spawnmob command auch so ..;D



MFG
Name


Das wäre ne Möglichkeit. Probier ich morgen mal :D
habe jetzt zeitweise NoSpawn drauf. wäre natürlich besser wenn ich das nicht brauchen würde^^
STEAM: crypton25

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net