You are not logged in.

  • Login
Bitte besucht unser neues Forum unter https://forum.nitrado.net | Please visit our new Forum at https://forum.nitrado.net

SilverKid

User / Kunde

  • "SilverKid" started this thread

Posts: 7

  • Send private message

1

Sunday, December 30th 2018, 8:56pm

Fliege immer wieder vom Server mit merkwürdiger Fehlermeldung

Minecraft-Version:1.7.10

Arbeitsspeicher/RAM: 14GB

Problembeschreibung: Fliege immer wieder vom Server mit merkwürdiger Fehlermeldung

Serverlog/Latestlog/Forgelog als Anhang:

installierte Plugins: Modpack After Humans mit ein Paar zusatzmods (seit Anfang an am Server drauf, haben den Server schon 1 Jahr lang und keine Mods neu hinzugefügt mit Ausnahme des witchery Mods)




Hallo,
Ich hoffe das mir hier jemand helfen kann.


Folgendes ich hab seit einem Jahr nun schon meinen Server bei Nitrado der auch immer problemlos funktionierte. Seit einer Woche allerdings werde ich vom Server geschmissen mit der Meldung:
Silver_Kid_ lost connection:
TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false,
color=null, bold=null, italic=null, underlined=null, obfuscated=null,
clickEvent=null, hoverEvent=null}}

Wenn ich dann wieder auf den Server möchte fliege ich gleich wieder runter. Ich habe meinen Freund gebeten (der mit mir auf meinem Server spielt) sich mit meinem Account auf seinem PC anzumelden und versuchen auf den Server zu kommen leider wurde er auch sofort runter geschmissen. Als er sich dann wieder mit seinem Account angemeldet hat, konnte er wieder auf dem Server.

Nun meine Frage: Woran kann es liegen? Ich bin in Minecraft in meinem Haus um hergelaufen, habe nichts aufgehoben oder verändert ich bin nur durch das Haus gegangen und wurde eben mit diesem Fehler in der Log Datei runter geschmissen. Ich kann zwar auf den Server wenn ich mein Inventar in den Spieler Dateien lösche, habe aber nach 10 Minuten wieder den selben Fehler und flieg vom Server auf den ich dann nicht mehr rauf kann. Gibt es noch eine andere Datei die eventuell beschädigt sein kann oder eine andere Ursache da wir schon sehr viel probiert haben und uns nun einfach nichts mehr einfällt.

Wir haben schon folgendes versucht: Minecraft, Technic Launscher und Java neu Installieren, von einem anderen PC aus versucht (die betroffenen Spieler fliegen trotzdem während andere nicht von dem Fehler betroffen sind und spielen können am selben PC), die Internet Verbindung überprüft, den Ping zum Server überprüft, alle Mods und Configs kontrolliert und neu Installiert, wir haben die Welt mit forge.cfg TileEntity und Entity true gestartet um evt. Schäden zu fixen, den Server auf Fehler überprüft, sowie dem Launcher den max RAM zugewiesen.


Auch an den Support haben wir uns gewendet doch die konnten uns bis jetzt leider auch nicht helfen.

Ich weis nicht mehr was ich noch versuchen könnte und habe auch im Internet nichts gefunden ich hoffe das mir irgendjemand hier helfen kann.


Danke schon mal im voraus.


Im Anhang befinden sich der aktuelle Log vom Server und der Crash Report von Minecraft der erstellt wurde da sich Minecraft beendet wenn ich vom Server fliege.
SilverKid has attached the following files:

This post has been edited 3 times, last edit by "SilverKid" (Jan 1st 2019, 4:11pm)


BladeOfHell

User / Kunde

  • "BladeOfHell" is male

Posts: 8

Location: Köln

Occupation: Informationstechnischer Assistent

  • Send private message

2

Thursday, January 10th 2019, 2:49am

Einmal bitte ohne "The SecretRoomsMod" (secretroomsmod-1.7.10-4.7.1.406.jar) den Server starten und ggf. eine neue Map versuchen (deine Jetzige umbenennen in zB. Alte_Welt.

SilverKid

User / Kunde

  • "SilverKid" started this thread

Posts: 7

  • Send private message

3

Friday, January 11th 2019, 6:40pm

Hallo BladeOfHell
Danke für Ihre Hilfe bei meinem Problem.
Ich wollte nur fragen ob Sie wissen warum dieser Fehler aufgetreten ist und ausgerechnet nur bei mir da es bei mein Freund funktioniert, er kann den Server einwandfrei betreten und hatte noch nie einen Fehler. Als er sich zum Test auf seinem Laptop dann mit meinem Account angemeldet hatte konnte er nicht auf dem Server, als er sich dann aber wieder mit einem Account angemeldet hatte konnte er wieder ganz normal drauf.

Ich habe mittlerweile den Mod wieder hinzugefügt und komme auch weiterhin auf den Server. Mir ist unklar wieso der Mod das Problem ist, da dieser von Anfang an am Severer ist und kann mir auch nicht erklären warum der Fehler so plötzlich auftritt daher möchte ich Sie fragen ob Sie mir sagen können wie das zu Stande gekommen ist, damit ich den Fehler in Zukunft vermeiden und selbst beheben kann.
Mit freundlichen Grüßen
SilverKid

thunfischbaum

User / Kunde

  • "thunfischbaum" is male

Posts: 254

Location: %JAVA_HOME%

Occupation: Fachinformatiker für Systemintegration

Thanks: 5

  • Send private message

4

Friday, January 11th 2019, 9:09pm

Moin Silverkid,
probiere einmal bitte deinen Player Ordner und Dateien zu löschen. Diese befinden sich im world Ordner unter players. Alle Items die du im Inventar werden durch diesen Vorgang gelöscht. Packe sie ihn Kisten oder ins Inventar deines Kumpels (oder "Kumpelin" ;)). Dieser Vorgang setzt dein Spielprofil auf dem Server zurück. Vielleicht behebt das den Fehler.
Nicht vergessen vorher deine Items zu sichern.
Berichte gerne von deinen Beobachtungen und schreibe sie hier hinein ;)

Viel Erfolg,
thunfischbaum

SilverKid

User / Kunde

  • "SilverKid" started this thread

Posts: 7

  • Send private message

5

Saturday, January 12th 2019, 1:11pm

Hallo Thunfischbaum

Danke für deine Hilfe.
Meine Player Datei habe ich schon ein paar mal gelöscht und ich konnte danach auch wieder auf den Server, allerdings kam nach ca. 10 Minuten der Fehler erneut das ich vom Server flog und nicht mehr rauf konnte ohne die Datei wieder zu löschen was zu einer endlos schleife von Datei löschen und nach 10 Minuten runter fliegen wurde.

Als ich dann meine alte Datei wieder auf den Server geladen hatte, die ich vor dem Löschen auf meinem PC gesichert hatte, konnte ich ebenfalls wieder auf den Server obwohl das vorher nicht möglich war. Allerdings dauerte es auch wieder nur ca. 10 Minuten bis der Fehler erneut auftrat und ich wieder nicht mehr drauf konnte.

Mit freundlichen Grüßen
SilverKid

thunfischbaum

User / Kunde

  • "thunfischbaum" is male

Posts: 254

Location: %JAVA_HOME%

Occupation: Fachinformatiker für Systemintegration

Thanks: 5

  • Send private message

6

Saturday, January 12th 2019, 6:39pm

Hi,

wie sieht das mit anderen Server aus? Hast du das Problem bei anderen Server ebenfalls?
LG
//EDIT

Source code

1
[20:09:28] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 2918ms behind, skipping 58 tick(s)

Deine Serverauslastung ist zu hoch. Kannst du mal schauen ob diese Fehlermeldung auch auftaucht wenn andere Spieler auf dem Server sind?

SilverKid

User / Kunde

  • "SilverKid" started this thread

Posts: 7

  • Send private message

7

Saturday, January 12th 2019, 8:20pm

Hallo

Nein nur auf meinen Server habe ich dieses Problem.

Das mit der Serverauslastung hat sich am nächsten Tag von selbst erledigt das hat der Server ca einmal im Monat das er mal für einen Tag langsam und überlastet ist das hat sich aber immer von selbst gegeben. Und an dem Tag ist das dann auch bei allen Spielern das der Server langsam ist und dann nicht mitkommt wenn sich die Spieler zu schnell bewegen. Wie gesagt das hat er einmal im Monat ca und hat sich dann am nächsten Tag von selbst erledigt mehr kann ich dazu leider nicht sagen da ich auch keine Ursache dafür finden kann und so auch nichts weiter angezeigt wird.

Vielen dank für deine Antwort :)

thunfischbaum

User / Kunde

  • "thunfischbaum" is male

Posts: 254

Location: %JAVA_HOME%

Occupation: Fachinformatiker für Systemintegration

Thanks: 5

  • Send private message

8

Saturday, January 12th 2019, 8:48pm

Hi Silverkid,
Alles klar, magst du mal Serverauslastungsscreenshots machen? Die kannst du im Servercontrolpanel sehen. Mache das bitte 1x mit Spielern und einmal ohne.

Lg,
thunfischbaum

SilverKid

User / Kunde

  • "SilverKid" started this thread

Posts: 7

  • Send private message

9

Sunday, January 13th 2019, 9:29pm

Hallo

Hier sind die beiden Screenshots von der Serverauslastung mit und ohne Spieler :)


LG
SilverKid
SilverKid has attached the following files:

BladeOfHell

User / Kunde

  • "BladeOfHell" is male

Posts: 8

Location: Köln

Occupation: Informationstechnischer Assistent

  • Send private message

10

Monday, January 14th 2019, 8:14pm

Hallo BladeOfHell
Danke für Ihre Hilfe bei meinem Problem.
Ich wollte nur fragen ob Sie wissen warum dieser Fehler aufgetreten ist und ausgerechnet nur bei mir da es bei mein Freund funktioniert, er kann den Server einwandfrei betreten und hatte noch nie einen Fehler. Als er sich zum Test auf seinem Laptop dann mit meinem Account angemeldet hatte konnte er nicht auf dem Server, als er sich dann aber wieder mit einem Account angemeldet hatte konnte er wieder ganz normal drauf.

Ich habe mittlerweile den Mod wieder hinzugefügt und komme auch weiterhin auf den Server. Mir ist unklar wieso der Mod das Problem ist, da dieser von Anfang an am Severer ist und kann mir auch nicht erklären warum der Fehler so plötzlich auftritt daher möchte ich Sie fragen ob Sie mir sagen können wie das zu Stande gekommen ist, damit ich den Fehler in Zukunft vermeiden und selbst beheben kann.
Mit freundlichen Grüßen
SilverKid
Sry ich konnte leider nicht herauslesen ob durch dass entfernen dieser Mod dein Problem behoben wurde. Aber da du scheinbar nur Probleme über deinen Account hast tippe ich darauf dass es wirklich ein Spieler basierter Fehler ist. Um dies zu testen ist es nötig dass du wie @thunfischbaum bereits sagte deine Spieler Daten entfernst. Diese liegen allerdings nicht nur im World Ordner. Alle Spieler Daten sind in Folgenden Ordnern zu finden:
- {WeltName}/playerdata (oder auch /players) (Setzt dein Inventar und Standort zurück)
- {WeltName}/stats (Setzt deine Statistiken zurück)
- {WeltName}/data (Falls vorhanden)
- {voidWeltName}/playerdata (Falls vorhande)(Setzt ebenfalls dein Inventar und Standort zurück)

Sollte wirklich die Mod dass Problem gewesen sein empfehle ich dir diesen CrashLog an den Entwickler der Mod zu schicken da wir dir hier damit dann leider nicht weiter helfen können. (Fehler ist bei mir ebenfalls aufgetreten durch diese Mod)

SilverKid

User / Kunde

  • "SilverKid" started this thread

Posts: 7

  • Send private message

11

Wednesday, January 16th 2019, 1:07pm

Hallo BladeOfHell

Sorry für meine späte Antwort. Ja als ich den Mod entfernt habe ging es wieder ich konnte wieder ganz normal auf meinen Server rauf und spielen es lag also wirklich daran. Das was mich wundert ist das, als ich den Mod aus Interesse wieder drauf gegeben habe, ich den Server auch wieder betreten konnte und der Fehler aber bis jetzt nicht wieder aufgetreten ist (gott sei dank).

Was ich mit meiner Frage meinte ist, ob du weist wie dieser Mod meinen Fehler auslösen konnte und wieso es nur einen Spieler betrifft. Ich habe bis jetzt lediglich die Erfahrung gemacht, dass ein durch einen Mod verursachter Fehler alle betrifft, daher würde es mich einfach Interessieren wie das zu Stande gekommen ist, damit ich solche Fehler in Zukunft vermeiden kann wenn möglich.

Vielen Dank für deine Hilfe :)
SilverKid


Ps: Entschuldige für meine verwirrende Formulierung bei meiner vorherigen Nachricht

thunfischbaum

User / Kunde

  • "thunfischbaum" is male

Posts: 254

Location: %JAVA_HOME%

Occupation: Fachinformatiker für Systemintegration

Thanks: 5

  • Send private message

12

Wednesday, January 16th 2019, 2:50pm

Hallo nochmal,
dann ist ja erstmal wieder alles in Butter hier. Zu deiner Frage wie so etwas auftreten kann:
Wir Spieler können da relativ wenig draus schließen. Da soltlest du dich mit deinen Logs und einer Beschreibung was genau passiert ist beim Entwickler melden. Der kann da mehr helfen.

Lg und viel Spaß beim Spielen!
thunfisch

P.S. Über ein "Dankeschön" würde ich mich freuen :)

1 registered user thanked already.

Users who thanked for this post:

SilverKid (18.01.2019)

SilverKid

User / Kunde

  • "SilverKid" started this thread

Posts: 7

  • Send private message

13

Friday, January 18th 2019, 11:47pm

Hallo

Vielen vielen Dank an euch beide für eure Hilfe und für all die schnellen Antworten die ich von euch bekommen habe, ich werde euren Rat befolgen und mich beim Entwickler melden. :)

Nochmal vielen Dank :)

Bitte besucht unser neues Forum unter https://forum.nitrado.net| Please visit our new Forum at https://forum.nitrado.net